Reactor Dependency Convergence

Legend:
[Error]
At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 8
Number of dependencies (NOD): 83
Number of unique artifacts (NOA): 96
Number of version-conflicting artifacts (NOC): 10
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA):
[Error]
 86 %
Ready for release (100% convergence and no SNAPSHOTS):
[Error]
 Error
You do not have 100% convergence.

Dependencies used in modules

com.fasterxml.jackson.core:jackson-annotations

[Error]
2.8.0
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
          \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
             \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.8.0:compile - omitted for conflict with 2.9.7)

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
          \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
             \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
                \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.8.0:compile - omitted for conflict with 2.9.7)

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
          \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
             \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.8.0:compile - omitted for conflict with 2.9.7)

2.8.4
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.8.4:compile - omitted for conflict with 2.9.7)

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
          \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.8.4:compile - omitted for conflict with 2.9.7)

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.8.4:compile - omitted for conflict with 2.9.7)

2.9.0
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
       \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
          \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.9.0:compile - omitted for conflict with 2.9.7)

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
          \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
             \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.9.0:compile - omitted for conflict with 2.9.7)

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
       \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
          \- (com.fasterxml.jackson.core:jackson-annotations:jar:2.9.0:compile - omitted for conflict with 2.9.7)

2.9.7
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.core:jackson-annotations:jar:2.9.7:compile

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- com.fasterxml.jackson.core:jackson-annotations:jar:2.9.7:compile

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.core:jackson-annotations:jar:2.9.7:compile

com.fasterxml.jackson.core:jackson-core

[Error]
2.8.4
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       +- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.8.4:compile
       |  \- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)
       \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
          +- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)
          \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
             \- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
          +- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.8.4:compile
          |  \- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)
          \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
             +- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)
             \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
                \- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       +- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.8.4:compile
       |  \- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)
       \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
          +- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)
          \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
             \- (com.fasterxml.jackson.core:jackson-core:jar:2.8.4:compile - omitted for conflict with 2.9.7)

2.9.7
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
       +- com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile
       \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
          \- (com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile - omitted for duplicate)

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
          +- com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile
          \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
             \- (com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile - omitted for duplicate)

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
       +- com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile
       \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile
          \- (com.fasterxml.jackson.core:jackson-core:jar:2.9.7:compile - omitted for duplicate)

com.fasterxml.jackson.core:jackson-databind

[Error]
2.8.4
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       +- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.8.4:compile
       |  \- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)
       \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
          +- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)
          \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
             \- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
          +- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.8.4:compile
          |  \- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)
          \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
             +- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)
             \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
                \- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- org.glassfish.jersey.media:jersey-media-json-jackson:jar:2.25.1:compile
       +- com.fasterxml.jackson.jaxrs:jackson-jaxrs-base:jar:2.8.4:compile
       |  \- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)
       \- com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider:jar:2.8.4:compile
          +- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)
          \- com.fasterxml.jackson.module:jackson-module-jaxb-annotations:jar:2.8.4:compile
             \- (com.fasterxml.jackson.core:jackson-databind:jar:2.8.4:compile - omitted for conflict with 2.9.7)

2.9.7
  1. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
       \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile

  2. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT:compile
       \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
          \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile

  3. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- com.fasterxml.jackson.datatype:jackson-datatype-jdk8:jar:2.9.7:compile
       \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.7:compile

commons-beanutils:commons-beanutils

[Error]
1.8.0
  1. pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT
    \- commons-configuration:commons-configuration:jar:1.7:compile
       \- commons-digester:commons-digester:jar:1.8.1:compile
          \- (commons-beanutils:commons-beanutils:jar:1.8.0:compile - omitted for conflict with 1.8.3)

  2. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT:compile
       \- commons-configuration:commons-configuration:jar:1.7:compile
          \- commons-digester:commons-digester:jar:1.8.1:compile
             \- (commons-beanutils:commons-beanutils:jar:1.8.0:compile - omitted for conflict with 1.8.3)

  3. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT:compile
       \- commons-configuration:commons-configuration:jar:1.7:compile
          \- commons-digester:commons-digester:jar:1.8.1:compile
             \- (commons-beanutils:commons-beanutils:jar:1.8.0:compile - omitted for conflict with 1.8.3)

  4. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- commons-configuration:commons-configuration:jar:1.7:compile
       \- commons-digester:commons-digester:jar:1.8.1:compile
          \- (commons-beanutils:commons-beanutils:jar:1.8.0:compile - omitted for conflict with 1.8.3)

  5. pl.frati.teryt:teryt-test-service:jar:3.2.1-SNAPSHOT
    \- commons-configuration:commons-configuration:jar:1.7:compile
       \- commons-digester:commons-digester:jar:1.8.1:compile
          \- (commons-beanutils:commons-beanutils:jar:1.8.0:compile - omitted for conflict with 1.8.3)

1.8.3
  1. pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT
    \- commons-configuration:commons-configuration:jar:1.7:compile
       \- commons-beanutils:commons-beanutils:jar:1.8.3:compile

  2. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT:compile
       \- commons-configuration:commons-configuration:jar:1.7:compile
          \- commons-beanutils:commons-beanutils:jar:1.8.3:compile

  3. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT:compile
       \- commons-configuration:commons-configuration:jar:1.7:compile
          \- commons-beanutils:commons-beanutils:jar:1.8.3:compile

  4. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- commons-configuration:commons-configuration:jar:1.7:compile
       \- commons-beanutils:commons-beanutils:jar:1.8.3:compile

  5. pl.frati.teryt:teryt-test-service:jar:3.2.1-SNAPSHOT
    \- commons-configuration:commons-configuration:jar:1.7:compile
       \- commons-beanutils:commons-beanutils:jar:1.8.3:compile

1.9.2
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-core:jar:2.0.1:compile
       \- pl.frati.teryt:teryt-core-hibernate:jar:2.0.1:compile
          \- pl.frati.dynx:dynx-hibernate:jar:2.5.0:compile
             \- pl.frati.dynx:dynx-beanutils:jar:1.5.8:compile
                \- (commons-beanutils:commons-beanutils:jar:1.9.2:compile - omitted for conflict with 1.8.3)

commons-configuration:commons-configuration

[Error]
1.10
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-core:jar:2.0.1:compile
       \- pl.frati.teryt:teryt-core-hibernate:jar:2.0.1:compile
          \- pl.frati.dynx:dynx-hibernate:jar:2.5.0:compile
             \- (commons-configuration:commons-configuration:jar:1.10:compile - omitted for conflict with 1.7)

1.7
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    +- commons-configuration:commons-configuration:jar:1.7:compile
    \- pl.frati.teryt:teryt-core:jar:2.0.1:compile
       \- pl.frati.teryt:teryt-core-api:jar:2.0.1:compile
          \- (commons-configuration:commons-configuration:jar:1.7:compile - omitted for duplicate)

commons-logging:commons-logging

[Error]
1.1.1
  1. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT:compile
       \- commons-configuration:commons-configuration:jar:1.7:compile
          +- commons-digester:commons-digester:jar:1.8.1:compile
          |  \- (commons-logging:commons-logging:jar:1.1.1:compile - omitted for duplicate)
          \- commons-beanutils:commons-beanutils:jar:1.8.3:compile
             \- (commons-logging:commons-logging:jar:1.1.1:compile - omitted for duplicate)

1.1.3
  1. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    +- pl.frati.teryt:teryt-service-client-configurator:jar:3.2.1-SNAPSHOT:compile
    |  \- commons-configuration:commons-configuration:jar:1.7:compile
    |     \- commons-logging:commons-logging:jar:1.1.3:compile
    \- org.apache.httpcomponents:httpclient:jar:4.3.6:test
       \- (commons-logging:commons-logging:jar:1.1.3:compile - scope updated from test; omitted for duplicate)

org.javassist:javassist

[Error]
3.18.1-GA
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- org.hibernate:hibernate-c3p0:jar:4.3.11.Final:compile
       \- org.hibernate:hibernate-core:jar:4.3.11.Final:compile
          \- (org.javassist:javassist:jar:3.18.1-GA:compile - omitted for conflict with 3.20.0-GA)

3.20.0-GA
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    +- pl.frati.teryt:teryt-core:jar:2.0.1:compile
    |  \- pl.frati.teryt:teryt-core-hibernate:jar:2.0.1:compile
    |     \- org.javassist:javassist:jar:3.20.0-GA:compile
    \- org.glassfish.jersey.core:jersey-server:jar:2.25.1:compile
       \- org.glassfish.hk2:hk2-locator:jar:2.5.0-b32:compile
          \- (org.javassist:javassist:jar:3.20.0-GA:compile - omitted for duplicate)

org.ow2.asm:asm

[Error]
4.2
  1. pl.frati.teryt:teryt-service-client-api:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- cglib:cglib:jar:3.1:test
          \- (org.ow2.asm:asm:jar:4.2:test - omitted for conflict with 5.0.3)

  2. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- cglib:cglib:jar:3.1:test
          \- (org.ow2.asm:asm:jar:4.2:test - omitted for conflict with 5.0.3)

  3. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- cglib:cglib:jar:3.1:test
          \- (org.ow2.asm:asm:jar:4.2:test - omitted for conflict with 5.0.3)

  4. pl.frati.teryt:teryt-test-service:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- cglib:cglib:jar:3.1:test
          \- (org.ow2.asm:asm:jar:4.2:test - omitted for conflict with 5.0.3)

5.0.3
  1. pl.frati.teryt:teryt-service-client-api:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- org.ow2.asm:asm:jar:5.0.3:test

  2. pl.frati.teryt:teryt-service-client-rest:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- org.ow2.asm:asm:jar:5.0.3:test

  3. pl.frati.teryt:teryt-service-integrity-tests:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- org.ow2.asm:asm:jar:5.0.3:test

  4. pl.frati.teryt:teryt-test-service:jar:3.2.1-SNAPSHOT
    \- org.easymock:easymock:jar:3.3.1:test
       \- org.ow2.asm:asm:jar:5.0.3:test

org.slf4j:slf4j-log4j12

[Error]
1.7.25
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- org.slf4j:slf4j-log4j12:jar:1.7.25:compile

1.7.7
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-core:jar:2.0.1:compile
       \- (org.slf4j:slf4j-log4j12:jar:1.7.7:compile - omitted for conflict with 1.7.25)

pl.frati.dynx:dynx-persistence

[Error]
2.2.0
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-core:jar:2.0.1:compile
       \- pl.frati.teryt:teryt-core-api:jar:2.0.1:compile
          \- pl.frati.dynx:dynx-domain-utils:jar:3.2.0:compile
             \- (pl.frati.dynx:dynx-persistence:jar:2.2.0:compile - omitted for conflict with 2.3.0)

2.3.0
  1. pl.frati.teryt:teryt-service:war:3.2.1-SNAPSHOT
    \- pl.frati.teryt:teryt-core:jar:2.0.1:compile
       \- pl.frati.teryt:teryt-core-hibernate:jar:2.0.1:compile
          +- pl.frati.dynx:dynx-persistence:jar:2.3.0:compile
          \- pl.frati.dynx:dynx-hibernate:jar:2.5.0:compile
             \- (pl.frati.dynx:dynx-persistence:jar:2.3.0:compile - omitted for duplicate)